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Learning Services IT Guides 

Excel – Advanced features 

 
This guide is intended for those who already know their way around a spreadsheet 
and will look at some slightly more advanced features such as: 

1. Creating a form 
2. Freezing column and row titles 
3. Adding notes to cells 
4. Conditional formatting 
5. Using more than one worksheet  
6. Using advanced formulas 
7. Using the If function  
8. Statistical Functions – Averages, Standard Deviations, Correlations 
9. Sharing and protecting a spreadsheet 

 
 
 

Creating a form 
Excel can be used for creating forms.  The grid format of the spreadsheet makes it 
easier to make boxes and lines. 

 

 Putting borders around cells 
Highlight the cell, or selection of cells, you want to put a border around.  Click on 

the borders   button from the Font group on the Home tab, select the type 
of border you would like, and you can alter the colour and thickness of line etc. 

 

 

 

 

 Shading cells 
To shade an area of cells, 
first highlight the area you 
want to shade.  Click on 

Cell Styles, from the 

Styles group on the Home 

tab. You will be presented 
with a palette of different 
shades, colours and styles 
to choose from. Make your 
selection to change the 
cells. 

 

 

 
 
 Creating Drop Down Menus 
Type the data you want to include in your drop down list in a single column in an 
area of the spreadsheet that is not included in your form, you may want to use 
another sheet .  



© LIPA Learning Services 2011 2 

Select the cell you want the drop down list to 
appear in.  
 

From the Data tab select Data Validation  
 
 
 
 

 

 

 

 

 

Select List from the Allow box 

 

 
 
 
 

 
 
 
 
 
In the Source box enter the data range of your 
drop down list (G1:G4) and press ok 
 
 
 
 
 
 
 
 

 

 

 

 
The drop down list should now appear 
in the selected cell 
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Freezing Column and Row Headings 
 
Where a spreadsheet contains many rows and columns of data, you may find by 
scrolling down or across the spreadsheet you lose sight of the column or row titles 
making the data difficult to understand. You can freeze the titles so that they are 
always visible no matter how far you scroll down. 

 Click and drag the vertical split box  at the top of the vertical scroll bar to 
just below the row with the column titles, the row will now show in a different 
pane 

 

 From the View tab, select Freeze Panes 

from the Windows group, then select  

Freeze Top Row from the menu. The split 
divider is now replaced by a line and the 
column titles remain visible when scrolling 
down the worksheet.  To freeze row titles 
follow same procedure dragging the 
horizontal split box to the right of Column A 

 
 
 
 
 

Adding notes to cells 
 You can add a note to any cell, this can be useful if you want to add additional 

information without crowding the spreadsheet. 
 
 Simply click with the right hand mouse button on 

the cell you want to add the note to and select 

Insert Comment from the drop down menu.   
 
A yellow box will appear allowing you to type in 
your comment. This is not visible at all times as it 
would obscure other cells, instead a small red 
triangle appears in the corner of the cell to indicate it holds a comment.  When 
the mouse moves over the red triangle the comment box appears. 

 
 
 
 
 
 
 

Conditional Formatting 
It is possible to apply a certain type of formatting to data only if it satisfies certain 
criteria, e.g . you may want data in a cell range to show as light red with dark red text 
if the value is greater than a specified amount so it can be easily identified. 
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 Highlight the range of cells that need to be formatted 
 
 
 

 From the Home tab, click on Conditional 

Formatting in the Styles group. 
 
 
 
 

  From the Highlighting Cell Rules menu 

select Greater than. 
 
 
 

 
  
 A box will appear for you to specify an amount and the type of formatting you 

want if the value satisfies that criteria. 
 
 
 

 

 

 

 

 
 From Conditional Formatting menu you can also emphasise top ten items, data 

which is above or below a specified average etc. 

 

 

Using more than one worksheet. & Linking Data 
When you open a new spreadsheet, along the bottom you will see a number of tabs 
numbered sheet 1 - sheet 16.  These are like pages in Word, but each sheet is 
16384 rows deep and 256 columns wide!  You can use different sheets to store 
different information.  This prevents any one sheet becoming too large and unwieldy. 

 

 To begin a new sheet, click on the Insert Worksheet tab at the bottom of the 

worksheet  and a new sheet will open up. 

 

 You can rename a sheet by clicking on the tab with the right mouse button.  

Choose Rename from the menu and type in what you want to call it.  To delete a 

sheet, click again with the right mouse button, but choose Delete instead. 

 

 If you want to change the order of your sheets click on the tab with the left 
mouse button, hold it down and drag it to its new location. 
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 Linking Data – I f you need to copy data from one worksheet to another (or even 
from one cell or spreadsheet to another)  it is possible to create a link between 
the two sets of data so that any editing on one set of data will automatically 
update the other. 

 
 
 
 

Highlight the data to be copied, right click on 

the area and select Copy from the menu 
 

 

 
 
 
 

 
 
 
 
 
Open up the new worksheet, right click and select 

Paste Special from the menu 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

From the Paste Special box select Paste 

Link – this will ensure both sets of data are 
linked and any changes to one set  will effect 
the other 
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Using Advanced Formulas 
 

You can include more than one mathematical operation in a formula, in fact you 
can create quite complex formulas but remember there is a mathematical order in 
which calculations are carried out. As a rule anything in brackets is carried out first, 
followed by square roots & powers etc, then division, multiplication, addition and 
subtraction. 

 
 
 Displaying and using Percentages in Excel 

           When using percentages in a formula they should be entered as a fraction or a 
decimal e.g. 30% is 30/100 or 0.3 

 
If you enter 30% in a cell Excel displays it as 30% but stores it as 0.3 

If you format the cells with the  icon, found on the Home tab it will 
automatically multiply any figure entered by 100 so if you enter 30 it will display 
3000% but store it as 30 
 
So either type in the % sign after each figure or type in the figure as a decimal 
then use the toolbar icon to display it as a percentage. 
 
 

To calculate a percentage of a number 
 
To find a percentage of a number simply multiply the number by the percent 
number 
 

Example 
 

 
 
 
The formula to find 17% of £320 can be expressed as B3*17/100, or B3*0.17 or 
simply B3*17% 
 
 

Calculating a percentage increase 
 
Divide the smaller number by the larger number (the part by the whole) and 
multiply by 100. 
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Example  

 
 

 
 
 

 

 

 

 

 
To find the percentage increase of the number of students enrolled from the 
2005 figures,  divide the increase D3 (the part) by the 2005 figure B3 (the whole) 

and multiply by 100 or instead of multiplying by 100, format the cells in the E 

column with the  icon and the result of D3/B3 will automatically be multiplied 
by 100. 

 

 

Calculating the Percentage of a Total 

 
Divide the value by the total and multiply by 100 
 

Example 

 

 

 

 

 

 

 

 

 

 

 

 

B3 is the value divided by the total B7, which should be set as an absolute 

reference if it is to be copied to the other cells, multiply by 100 or format the cell 
for % 

 

 

 Using Brackets - You can use brackets to separate different parts of a formula. 
For example to calculate the income for  Short Summer Courses at LIPA 
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We need to add the Fee for the course with the VAT and then multiply by the 
number of students enrolled on the course. To get Excel to do the addition first we 
need to put that part of the formula in brackets, anything in brackets is calculated 
first, the result will then be multiplied by the number of students. So the formula will 

be   =B4*(C4 +D4) if you leave out the brackets you will get a completely different 
answer. Care must be taken to establish the mathematical order when creating 
formulas 

  
 

 
 
Using Functions in Excel 
You can perform a wide range of functions in Excel, these are pre-set formulas and 

are found on the Formulas tab in the Function Library group 
 
 
 
 
 
 
 
 

 

 

 

 

 

IF Function 
 

 A useful function is the IF function. This is a logical function, which allows you to 
display a customised message in a cell depending on the value displayed in 
another cell. 

 

Example 
 
 
 
 
 
 
 
 
 
 

 
It may be decided that if the income from a particular course does not exceed  
£3,000 then it should be cancelled. In Column C we can use the IF function to see 
which courses should run. 
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 Click on C4 and from the Formulas tab click on Insert Function 
icon  

 
 
 
 
 
 

 In the Insert Function box select the If 

           function and ok. and the Function 

Arguments box will open.  
 

 
 
 
 
 
 

 
 
 

In the Logical test box we are saying If it 
is true that the value of B4 is greater 
than £3000 then display ‘Run’, if  not 

display ‘Cancel’. Press OK 
 
 
 
 
 

 
 
 
 

 

 
 The result will appear in 

cell C4, replicate the 
formula down to C7 to 
show the rest of the 
results 
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Statistical Functions – Averages, Standard Deviations & Correlations 
 

 

 

 
To calculate the average (mean) of a set of 
figures, select the cell that the  answer is to 
appear in. 
 

click on the Insert Function icon 

from the Formulas tab 
 
 

 

Select Statistical category in the Insert 

Function box, highlight the Average function 
and press OK 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Function Arguments box will appear 
with the data range to be used in the 
calculation (B4:B12), press OK to 
complete the calculation 
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The Standard Deviation measure will show the variation of values in a set of data 
from the calculated average.  
 
 
To calculate the Standard Deviation in a set of figures  
 
 
 
 

 
Select the cell the calculation is to appear in 

 

 

click on the Insert Function  icon 

from the Formulas tab 

 

 

 

Select Statistical category in the Insert 

Function box, highlight the STDEV function and 
press OK 
 
 
 
 

 

 

 

 

 

 

 

 

 

In the Function Arguments box enter 
the data range in the Number1 box 
(B4:B12) then press ok to complete the 
calculation. 
 
 
 
The higher the Standard Deviation the 
greater the variation of the values from 
the average, the lower the Standard 
Deviation the closer the values are to 
the average 

 
 
Correlation is a measure to show the 
relationship between two sets of data 
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To calculate the correlation of two sets of data 
 
 

 

 
Select the cell the calculation is to appear 
in 

 

 

click on the Insert Function  icon 

from the Formulas tab 

 

 

 

Select Statistical category in the Insert 

Function box, highlight the CORREL 
function and press OK 

 

 

 

 

 

 

 

 
 
 
 

In the Function Arguments box enter 
the first data range in the Array1 box 
(B4:B12) enter the second data range 
in the Array2 box (C4:C12), then press 
ok to complete the calculation. 

 

 

 
The Correlation measure will produce 
a number between 0 and 1, the higher 
the number the stronger the 
relationship between the two sets of 
data. 
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Sharing and Protecting a Spreadsheet 
 
As spreadsheets can contain a lot of detailed and sensitive information, it may be 
necessary to protect the spreadsheet especially if it is shared by other people. 
 

You can protect the spreadsheet by making it read only this will prevent 
unauthorised people from deleting or editing any of the data. 
 

 From the Review tab, click on the Protect sheet icon  
 
 
 
 
 

 On the Protect Sheet dialogue box ensure the 

checkbox for Protect Sheet is ticked and enter 
a password, you will be asked to confirm the 
password and then the worksheet is protected 
against any unauthorised use.  

 
 
 
 
 
 

To unprotect the worksheet select the Unprotect Worksheet icon  
and enter the password when prompted. 

 
 

 If other people need to enter information into your spreadsheet you can 
restrict them to editing only specified cells. When you protect a worksheet 
Excel assumes you want all cells to be locked, to make some of the cells 
editable you will need to unlock them before you protect the worksheet. 

 
 
 

Highlight the cell range that people will be allowed to 

edit, on the Home tab select Format  in the Cells 
group. 
 
 
 

From the menu select Format Cells 
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Under the Protection tab ensure the Locked checkbox is unticked. You can 
now protect the worksheet 
and the specified cell range 
will allow editing. 
 
 
 
 
 
 
 
 

 It is possible to hide certain columns and rows from 
view. 

 

 Select the column or row. From the Home tab, 

select Format in the Cells group. 
 
 
 

 
From the menu select 

Hide column/row and 
the selected column or 
rows will disappear from 
view, to unhide the 
column/row follow the 
same procedure but 
choose ‘Unhide’ 
from the menu. 

 
 

 If you have a large spreadsheet you can protect it so that a specified  area will 
show on the screen every time it is opened. This prevents scrolling down to 
search for a particular area, which is to be worked on. 

 

Select the area of the worksheet which is to be prominent. From the Review 

tab select Protect Workbook icon 
 
 

From the Protect Structure and Windows 
dialogue box tick the Windows checkbox, enter a 
password. Now every time you open the 
spreadsheet the specified area should be 
prominent on the screen. 


